QuickBase has a new look! The new QuickBase is stylish, but it's also smart. Menus are pared down and more direct to save you loads of time. Plus, you can now customize pretty much anything from a handful of efficient screens that are designed to spare you unnecessary mouse clicks.

But change is hard. Review and print this cheat sheet of common tasks to get through the transition. You can also watch a video tour of the new screens:

Some important things to know:


The menu that appears when you click a table name has lots of new items to help Application Managers.

Getting Around: Viewing and Entering Data

If you want to... Select...
Organize your application list You control the list of application on your My QuickBase page. New menus make it easy. Learn more.
Search for an application On your My QuickBase page, in the menu above the application list, select Tools > Search for an application.
Open an application On your My QuickBase page, click the application name.
REPORTS (formerly VIEWS)
Create a report

Views are now called Reports. To create a new report:

  • Click the table you want to report on and within the menu that appears, select Create a new Report.
  • Or, select Customize > Create a new > report
Display a shared report Click the table featuring the report. Within the menu that appears, select the report from the list.
Display a personal report Click the table featuring the report. Within the menu that appears, select the report from the list.
Edit a shared report
  • Display the report. Move columns and change sort order by clicking a column heading (read more). Or, on the upper right of the screen, click Customize this Report.
  • In the table bar on any application page, click the table featuring the report. Within the menu that appears, select Customize --tablename-- table > Reports.
Edit a personal report Select Customize > Personal Reports.
Copy a report
  • Display the report. On the upper right of the screen, click Customize this Report. At the top of the Report Builder, click Save As and type in a title for the new copy.
  • In the table bar on any application page, click the table containing the report you want to copy. Within the menu that appears, select Customize --tablename-- table > Reports. Within the list of reports, locate the report you want to duplicate and click its Copy button.
DATA
Find a record In the menu bar on any application page, select Find.
Find a document In the menu bar on any application page, select Find > Advanced Find. Select the table containing file attachments. Within the first dropdown, select <Some attached file> then enter your search term. Read more.
Add a record In the table bar on any application page, click the table featuring the report. Within the menu that appears, select Add a new -- record--. (In your application the term for record may be different. You may see "Add a new Task" or "Add a new Order" for example.)
Access recently viewed records Select Recent.
Import or export data Select Customize > Import/Export.
Create a personal email notification or subscription Select Customize > Personal automated emails.

 

Customizing and Managing Applications

If you want to... Select...
Create an application On your My QuickBase page, select New from the menu above the application list. Or click the Create a new application button.
FIELDS & TABLES
Add a new field Select Customize > Create a new > field.
View and manage fields In the table bar on any application page, click the table whose fields you want to manage. Within the menu that appears, select Customize --tablename-- table > Fields.
Add a table Customize > Create a new > table.
Change table name In the table bar on any application page, click the table whose name you want to change. Within the menu that appears, select Customize --tablename-- table > Properties.
Convert a field into a table. Display a report that contains the field(s) you want to convert. Click the header and select Convert this field into a table. Read more.
Create a Relationship In the table bar on any application page, click one table you want to relate. Within the menu that appears, select Customize --tablename-- table > Relationships. On the upper right of the tab, click the New Relationship button.
Edit or Enhance a Relationship In the table bar on any application page, click one table in the relationship. Within the menu that appears, select Customize --tablename-- table > Relationships. Locate the relationship you want to change and click its Edit link.
APPLICATION MANAGEMENT AND HELP
Copy an application Select Customize > Import/Export. Click Copy this application.
Transfer application management Select Customize > Application. On the left side of the Settings tab, click Name and Description. To the right of Manager Name, click the Transfer link.
Customize application appearance Select Customize > Application. On the left side of the Settings tab, click Branding. Read more.
Create a guide for your end-users Create a QuickBase rich text page, then post it to the Help menu. Read how.
Change application name Select Customize > Application. On the left side of the Settings tab, click Name and Description.
Create a new Dashboard Select Customize > Application. Click the Pages tab. On the left side of the screen select Create a New page and make its type Dashboard.
Import or export data Select Customize > Import/Export.
FORMS
Create a custom form Select Customize > Create a New > Form.

Edit a form

  • Display the form and on the upper right of the page, click the Customize this form link.
  • In the table bar on any application page, click the table whose form you want to edit. Within the menu that appears, select Customize --tablename-- table > Forms.
Copy a form In the table bar on any application page, click the table whose form you want to edit. Within the menu that appears, select Customize --tablename-- table > Forms.
  • If the table has only one form associated with it, click the Create a new form button on the upper right of the tab. Then select Copy the existing form and click OK.
  • If the table has multiple forms associated with it, locate the form that you want to duplicate and click its Copy button.
Associate a Form with a Role In the table bar on any application page, click the table whose form you want to edit. Within the menu that appears, select Customize --tablename-- table > Forms. Click the + plus sign to left of Forms Usage to display the usage table and make assignments. Read more.
Associate a Form with a Report In the table bar on any application page, click the table whose form you want to edit. Within the menu that appears, select Customize --tablename-- table > Forms. Click the + plus sign to left of Forms Usage. Turn on the Override by Report checkbox. Read more.
EMAIL

Create automated email:

  • Notifications
  • Subscriptions
  • Reminders

Select Customize > Create a new > email notification.

Select Customize > Create a new > subscription.

Select Customize > Create a new > reminder.

Edit automated email

In the table bar on any application page, click the table you want to automate emails for. Within the menu that appears, select Customize --tablename-- table > Email.

 

USERS
Share an application Select Share > Share with a new user.
See and Manage application users Select Share > Manage Users.
ROLES / PERMISSIONS
Create a Role

Select Customize > Create a new > role.

 

Copy a Role Select Share > Manage Roles. Locate the role you want to copy. Click its More button and select Copy this role.
Edit Roles and Permissions

By table:

    • Select Share > Permissions (by table).
    • In the table bar on any application page, click the table whose form you want to edit. Within the menu that appears, select Customize --tablename-- table > Permissions.

By role:

     Select Share > Permissions (by role)

View all:

      Select Share > Manage Roles.

Specify which Reports to offer a Role

Select Share > Roles & Reports matrix

 

Tip: One handy screen provides access to all application development features. Have you seen the Application Site Map? If not, select Help > Application Site Map. Read more.

 

Related Topics

 

Return to top

© 1999-2011 Intuit Inc. All rights reserved.